План счетов.

    Первоначально необходимо определить какие счета будут использоваться в расчетах. Кроме этого нужно определить перечень субконто. Для этого необходимые данные сведем в таблицу, для удобства:

    Счет

    Аналитика

    10

    По местам хранения

    По приходным накладным

    По товару, услуге

    50

    нет

    51

    нет

    60.0

     По материально-ответственным лицам

    По приходным накладным

    По поставщикам

    60.01

    По договорам

    По подрядчикам

    61

    нет

    63

    нет

    76

    нет

    После определения видов субконто, перейдем непосредственно к их созданию. Для этого в окне метаданных в разделе "Виды Субконто"" вводим новое субконто.
    Создание Субконто.
    Идентификатор: МестоХранения
    Тип: С.Склады
    Триады: нет
    Неотрицательный: нет
    Отбор: да
    Цена: не назначена
    Валютная цена: не назначена
    Пустые субконто: нет
    Быстрый выбор: да


    Рис.13

    Аналогичным образом создадим оставшиеся виды субконто:

    • Поставщики
    • Подрядчики
    • ПриходнаяНакладная
    • ТоварУслуга
    • Договора
    • МОЛ

    Переходим к созданию плана счетов. В окне метаданных находим раздел "Планы Счетов".
    1. Входим в режим редактирования раздела "Планы счетов"


    Рис.14

    • Максимальная длина кода счета. Зададим 7;
    • Длина наименования счета 25;
    • Планы счетов. Нажимаем [Новый]. Появилось сообщение "Для бухгалтерии был добавлен Документ операций". [ОК]. Мы вошли в окошко свойств плана счетов;
    • Идентификатор – Наш. Шаблон кода - ###.###
    • Добавим реквизит "ПолноеНазвание" типа Строка неограниченной длины;
    • Количественный учет только по аналитике – Да. Аналитический учет – максимальное количество субконто– 3;
    • Редактировать счета – Обоими способами;
    • Основной план счетов – Наш;
    • Валютный учет. Справочник валют – С.Валюты;
    • Курс – Курс;
    • Кратность – Кратность;
    • Разделитель учета- не назначен;
    • Создадим форму счета.

     


    Рис.15

    • Отредактируем форму списка;
    • Добавим кнопку. Заголовок – "Печать", формула – Печать();
    • В модуле формы напишем процедуру:

     

    Процедура Печать()
    Сч=СоздатьОбъект("Счет");
    // Создаем в памяти экземпляр объекта "Счет"
    Сч.ИспользоватьПланСчетов(ИспользоватьПланСчетов());
    // Указываем, что будем использовать тот план счетов, который является
    // текущим в открытом списке счетов
    Таб=СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Таблица");
    Таб.ВывестиСекцию("Шапка");
    Сч.ВыбратьСчета();
    // Открываем подборку со списком счетов в текущем плане счетов
    Пока Сч.ПолучитьСчет()=1 Цикл
    Если Сч.ЭтоГруппа()=1 Тогда
    // Это счет либо субсчет, содержащий субсчета
    Таб.ВывестиСекцию("Группа");
    Иначе
    // Это счет не содержащий субсчетов, либо это субсчет самого нижнего уровня
    Таб.ВывестиСекцию("Строка");
    КонецЕсли;
    КонецЦикла;
    Таб.ТолькоПросмотр(1);
    Таб.ПараметрыСтраницы(2,,1,,,,,,,1,,);
    // ориентация "Ландшафт"
    Таб.Показать("План счетов");
    КонецПроцедуры

    17.Создадим печатную форму нашего плана счетов:


    Рис.16

    18. Заполняем форму плана счетов.
    19. Распечатаем полученный план счетов:


    Рис.17

    07.04.2011
© 2012-2016 Помощь бухгалтеру buhbest.com