Операция

    Создадим документ Операция. Документ создает операцию, которая состоит из проводок, а операция изменяет остатки в плане счетов. Войдем в режим редактирования документа. Идентификатор трогать не будем, журнал создадим. Создаем журнал "Операции", без каких-либо реквизитов, тип журнала - Обычный. Форму списка журнала создадим самую простую. В документе "Операция" укажем журнал – "Операции". Нумератор назначать не будем, Периодичность – в пределах года. Длина – 8, тип числовой, автоматическая нумерация – Да, контроль уникальности – Да. Реквизитов шапки либо табличной части этот вид документа не имеет – он просто констатирует факт создания бухгалтерской операции вручную.
    В дереве метаданных найдем объект "Операция". Войдем в режим редактирования объекта "Операция". Здесь укажем реквизиты.
    Операции состоят из проводок, войдем в редактор проводок.

    1. Сумма. Длина 10, при точности 2;
    2. Количество. Длина – 2, точность – 0;
    3. Валютная сумма – 10.2;
    4. Отбор. Отбор разрешим по дебету/кредиту по всем счетам и субсчетам;
    5. Отбор по валюте – Да;
    6. Отбор по количеству – Да;
    7. Отбор по сумме – Да;
    8. Отбор по валютной сумме – Да;
    9. Отбор по планам счетов отсутствует
    10. Сложные проводки – обязательно.


    Рис.18



    Рис.19

    Редактируем форму журнала проводок.

    1. Создаем форму списка
    2. Добавим в форму переключатель. Заголовок - "разделять по журналам", Идентификатор –"ФлагПоЖурналам", Формула – ПоЖурналам();
    3.  
    4. В модуле формы пропишем процедуру:

    Процедура ПриОткрытии()
    ФлагПоЖурналам=ВосстановитьЗначение("ФлагПоЖурналам");
    // Получаем сохраненное между сеансами значение
    Если ФлагПоЖурналам=1 Тогда
    ЗакладкиОтбора("НомерЖурнала",1);
    // Устанавливаем отбор
    Иначе
    ЗакладкиОтбора("",1);
    // Отключаем отбор
    КонецЕсли;
    КонецПроцедуры
    //=====================================================
    Процедура ПоЖурналам()
    СохранитьЗначение("ФлагПоЖурналам",ФлагПоЖурналам);
    // Указываем какое значение и под каким именем сохранить для
    // текущего пользователя между сеансами его работы
    Если ФлагПоЖурналам=1 Тогда
    ЗакладкиОтбора("НомерЖурнала",1);
    Иначе
    ЗакладкиОтбора("",1);
    КонецЕсли;
    КонецПроцедуры


    Рис.20

    После определения всех реквизитов проводок можно перейти к созданию формы Операции. Вернемся в окно редактирования свойств объекта метаданных Операция. Вызовем окно редактирования формы операции.



    Рис.21

    Напишем в модуле формы процедуру:

    Процедура ПриОткрытии()
    ИспользоватьВалюту(Константа.ОснВалюта);
    // Здесь мы указываем, что в форме операции по умолчанию использовать основную
    // валюту
    КонецПроцедуры

    Создадим и форму списка операций, самого простого вида.
    07.04.2011
© 2012-2016 Помощь бухгалтеру buhbest.com