Документ Приходная Накладная.

    Составляется при оприходовании на склад ТМЦ.
    В дереве метаданных выбираем раздел "Документы". Создаем новый документ.
    Идентификатор: ПриходнаяНакладная
    Журнал: ПриходныеНакладные
    Нумератор: Нет Периодичность: Год
    Длина: 5 Тип: число
    Уникальность: да Автонумерация: да
    Может являться основанием для документа любого вида?: нет


    Отредактируем журнал ПриходныеНакладные. Добавим в него две графы – Кол из реквизита таблицы Кол, и Сумма из реквизита Сумма. Настроим форму журнала.
    Перейдем к форме документа. Создаем ее.
    В поле Наименование пишем формулу Товар(), в поле Цена – Цена (). Под таблицей добавим текст с формулой для вычисления суммы по колонке Итог("Кол"), Итог("Сумма").
    В модуле формы документа пишем:

    Процедура ПриОткрытии()
    ПриЗаписиПерепроводить(1);
    КонецПроцедуры
    Процедура Наименование()
    Если Наименование.Выбран()=1 Тогда
    КонецЕсли;
    КонецПроцедуры
    Процедура Цена()
    Цена=Окр(Наименование.Цена);
    Сумма=Окр(Кол*Цена,2,1);
    КонецПроцедуры
    Процедура Печать()
    Таб=СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Таблица");
    Таб.ВывестиСекцию("Шапка");
    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл
    НС=НомерСтроки;
    // атрибут НомерСтроки возвращает номер текущей строки
    // табличной части
    Таб.ВывестиСекцию("Строка");
    КонецЦикла;
    ИтогПр=Формат(Итог("Сумма"),"ЧПДС");
    // В переменную ИтогПр мы выведем сумму прописью
    Таб.ВывестиСекцию("Подвал");
    Таб.ТолькоПросмотр(1);
    Таб.ПараметрыСтраницы(1,100,1);
    Таб.Показать("");
    КонецПроцедуры


    Рис.22

    Создаем печатную форму документа:


    Рис.23

    Теперь переходим к модулю документа. Пишем процедуру:


    Процедура ОбработкаПроведения()
    ВыбратьСтроки();
    Пока ПолучитьСтроку() = 1 Цикл
    Операция.НоваяПроводка();
    Операция.Дебет.Счет = СчетПоКоду("10",ПланыСчетов.Наш);
    Операция.Дебет.МестоХранения = Склад;
    Операция.Дебет.ТоварУслуга = Наименование;
    Операция.Дебет.ПриходнаяНакладная = ТекущийДокумент();
    Операция.Кредит.Счет = СчетПоКоду("60.0",ПланыСчетов.Наш);
    Операция.Кредит.Поставщики = Поставщик;
    Операция.Кредит.ПриходнаяНакладная = ТекущийДокумент();
    Операция.Кредит.МОЛ = ЧерезТов;
    Операция.Сумма = Сумма;
    КонецЦикла;
    Операция.Содержание = "Поступили материалы от поставщиков";
    Операция.СуммаОперации = Итог("Сумма");
    Операция.Автор = АвторДокумента;
    Операция.Записать();
    КонецПроцедуры


    Создадим документ в 1С:


    Рис.24

    Проведем накладную, документ отражается в журнале:


    Рис.25

    07.04.2011
© 2012-2016 Помощь бухгалтеру buhbest.com