Документ Доверенность

    Данный документ создается при получении товароматериальных ценностей, является оправдательным документом при передаче ТМЦ.

    1. Создаем документ
    2. Заполняем в окне редактирования необходимые данные
    3. Создаем форму документа
    4. В модуле формы пишем процедуру:

    Процедура ПриОткрытии()
    ПриЗаписиПерепроводить(1);
    КонецПроцедуры
    Процедура Печать()
    Таб=СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Таблица");
    Таб.ВывестиСекцию("Шапка");
    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл
    НС=НомерСтроки;
    // атрибут НомерСтроки возвращает номер текущей строки
    // табличной части
    Таб.ВывестиСекцию("Строка");
    КонецЦикла;
    // В переменную ИтогПр мы выведем сумму прописью
    Таб.ВывестиСекцию("Подвал");
    Таб.ТолькоПросмотр(1);
    Таб.ПараметрыСтраницы(1,100,1);
    Таб.Показать("");
    КонецПроцедуры

    5. Создаем печатную форму документа:


    Рис.31

    6.Создадим доверенность в 1С. Проведем документ. Он находит свое отражение в журнале по учету доверенностей "Доверенность"


    Рис.32


    Рис.33

    07.04.2011
© 2012-2016 Помощь бухгалтеру buhbest.com