Документ Договор

    На основании договоров производятся поставки ТМЦ и выполняются работы. Создадим два договора: "Договор поставки" и "Договор подряда".
    Процесс создания рассмотрим на примере договора поставки.
    1. В дереве метаданных в разделе "Документ" добавляем новый документ.
    2. В окно редактирования вносим соответствующие значения.
    3. Составляем форму документа.
    4. В модуле формы пишем процедуру:

    Процедура ПриОткрытии()
    ПриЗаписиПерепроводить(1);
    КонецПроцедуры
    Процедура Печать()
    Таб=СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Таблица");
    Таб.ВывестиСекцию("Шапка");
    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл
    НС=НомерСтроки;
    // атрибут НомерСтроки возвращает номер текущей строки
    // табличной части
    Таб.ВывестиСекцию("Строка");
    КонецЦикла;
    // В переменную ИтогПр мы выведем сумму прописью
    Таб.ВывестиСекцию("Подвал");
    Таб.ТолькоПросмотр(1);
    Таб.ПараметрыСтраницы(1,100,1);
    Таб.Показать("");
    КонецПроцедуры


    Рис.29

    1. Создаем печатную форму договора.
    2. В 1С заполняем форму договора, проводим его в журнале "Договора", смотрим печатную форму:


    Рис.30

    07.04.2011
© 2012-2016 Помощь бухгалтеру buhbest.com