Документ Акт выполненных работ

    Данный документ составляется при расчетах с подрядчиками, после завершения работы по договору подряда.
    Данный документ составляется по такому же принципу как и предыдуший.


    Рис.26

    1. Создаем форму документа
    2. в модуле формы пишем формулу:

    Процедура ПриОткрытии()
    ПриЗаписиПерепроводить(1);
    КонецПроцедуры
    Процедура ОбрВыпРаб()
    КонецПроцедуры
    Процедура Печать()
    Таб=СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Таблица");
    Таб.ВывестиСекцию("Шапка");
    ВыбратьСтроки();
    Пока ПолучитьСтроку()=1 Цикл
    НС=НомерСтроки;
    // атрибут НомерСтроки возвращает номер текущей строки
    // табличной части
    Таб.ВывестиСекцию("Строка");
    КонецЦикла;
    // В переменную ИтогПр мы выведем сумму прописью
    Таб.ВывестиСекцию("Подвал");
    Таб.ТолькоПросмотр(1);
    Таб.ПараметрыСтраницы(1,100,1);
    Таб.Показать("");
    КонецПроцедуры

    4.Составляем печатную форму документа:


    Рис.27

    5.Создадим документ В 1С:



    Рис.28

    Данный документ при проведении отражается в журнале "АктВыпРаб".

    07.04.2011
© 2012-2016 Помощь бухгалтеру buhbest.com